ActionFilters sample does not work or i miss something?  

  RSS

oakrom
New Member
Joined: 4 weeks  ago
Posts: 1
24 August 2017 14:40  

Hello. My problem is that, when i run sample project "ActionFilters" server is correctly started, when i entered into browser url  "localhost:8080", as result browser showed page with text "Not Found". After this i am trying enter "localhost:8080/people/1" but result also with text 'Not Found'. I thought may be i entered some thing wrong or this sample not worked? After this i was remove in code MVCProduces('application/json') attribute of GetPerson procedure, and run sample again and check this "localhost:8080/people/1", as result browser showed page with text {"FirstName":"Daniele","LastName":"Teti","DOB":"1975-05-02","Married":true}.        

Sample "ActionFilters", work without MVCProduces('application/json') attribute but with attribute doesn't work. After this i was try read about MVCProduces attribute in Developer Guide, but there nothing about it, please can some one help me to understanding MVCProduces attribute? Why this attribute included to this sample if this sample work without this attribute, may be i am checking sample by wrong way? 


ReplyQuoteLikeReport
Daniele Teti
Eminent Member
Joined: 6 months  ago
Posts: 42
4 September 2017 22:52  

Did you solved the problem as I told you on facebook group?

Daniele Teti
CEO & CTO @ bit Time Professionals
Embarcadero MVP
Books Author


ReplyQuoteLikeReport
  
Working

Please Login or Register